choose language

Deutsch Français 日本語 简体中文

See all Nokia sites

Viewing

Compatible OS

  • iOS 8.0 or higher 
  • Android 5.0 or higher

Compatible devices

  • iPhone 4S or higher
  • iPod Touch 5th Generation or higher
  • iPad (3rd Generation or higher, as well as any iPad Mini)
  • BLE (Bluetooth Low Energy) compatible Android device

Didn't find what you need? Here's how to get in touch.

Contact us